Issue
Planned Maintenance in Service Portal is missing some outages
Cause
The 'Planned Maintenance' Service Portal widget was customised
Resolution
Revert the 'Planned Maintenance' [sp_widget] to the out-of-box (OOB) version
- Go to the Planned Maintenance Portal page
- Click Ctrl + Right-click on the page and it will give you a list of options
- Choose Instance in Page Editor and check the Widget if it is a customised version of the widget
- Modify the UI page to use the out-of-box (OOB) widget 'Planned Maintenance' by choosing in the widget dropdown and Save
- If you have not added a custom version and have modified the out-of-box (OOB) version, you need to go to the platform or advanced view.
- In the navigation bar, type in sp_widget.list to go to the list of Service Portal widget records.
- Filter in the Name or the sys_id of the widget 'Planned Maintenance'
- In the Versions related list, select both Custom (current) and Upgrade version
- Click on Action on selected rows > Compare > Revert to Selected version which is the OOB version
- Save.
Baseline your customisation from the out-of-box (OOB) version