Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
The notification event "request.approval.inserted" is not triggered for approvals on request table - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • The notification event "request.approval.inserted" is not triggered for approvals on request table
KB0718692

The notification event "request.approval.inserted" is not triggered for approvals on request table


4085 Views Last updated : Jun 19, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


The notification event "request.approval.inserted" is not triggered for approvals on request table when the approvals are generated from the workflow for the first time.

 If the workflow has second approval activity, it triggers the correct event "request.approval.inserted" 

Release


Kingston

Cause


The business rules which triggers the related events on approval table is "Approval Events (Task)". Going through the script we can notice that if the class is "request", the expected event is "request.approval.inserted" but this is not happening when workflow creates approval on request table this is because at the time, Request is not yet available when workflow runs. Therefore, it fired the "approval.inserted" event instead of "request.approval.inserted" but in case if the workflow has second approval activity, it triggers event "request.approval.inserted" as it already has a Request. 

Resolution


The business rule is updated on London version and this issue is resolved in it. 
A simple workaround which can be used is that, replace line 2 from 

var task = current.sysapproval.sys_class_name;

to 

var task = current.sysapproval.sys_class_name || current.source_table; 

or replace line 2, line 7, line 12 from 
var task = current.sysapproval.sys_class_name; 
to 
var task = current.sysapproval.sys_class_name || current.source_table; 

One more thing to note, Once if below customizations are made then the upgrade process automatically skips changes to these objects.To Overwrite customizations during an upgrade Please refer below doc:
https://docs.servicenow.com/csh?topicname=t_OverwriteCustomizsDuringUpgrades.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.