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Users without the 'admin' role are not able to attach files (attachments) to closed incident records - Support and Troubleshooting
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KB0718509

Users without the 'admin' role are not able to attach files (attachments) to closed incident records


3323 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Users who do not have the 'admin' role when navigating to a closed incident record, they don't have the ability to attach files. They don't see the attachment icon and when they drag and drop a file onto the form, the system throws the following message:

"File attachments not allowed"

Release


All releases

Cause


This is caused by a Client Script which hides the attachment icon on the form. 

Along with the Client Script mentioned above, there are two OOB ACL which stop WRITE access to closed incident records.

Resolution 


Follow the steps below and ensure you test thoroughly on a sub-production instance first:

You may find that after performing the ACL changes, your users now have access to modify fields on the form.
This is something you need to take into consideration and accommodate for, with either using more ACLs against fields or UI Policies.


  1. Navigate to the "(BP) Hide Attachment Link when Closed" Client Script and deactivate the record.

    https://<instance_name>.service-now.com/sys_script_client.do?sys_id=5601ea5f0a0a0b4b0055644e71c28968

  2. Review the following ACLs and make the necessary changes in the condition field which stops WRITE access when the incident is in a closed state:

    https://<instance_name>.service-now.com/sys_security_acl.do?sys_id=66ec26370a0a0b0100a67b597d415b84
    https://<instance_name>.service-now.com/sys_security_acl.do?sys_id=66ecaf4d0a0a0b010029ce5027a8d56f

  3. Perform a cache.do on the instance once done.

    https://<instance_name>.service-now.com/cache.do


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