Issue
Symptoms
A non ITIL user is unable to see all the records in the incident table.
Release
Jakarta , Kingston , London
Cause
This is happening due to before query business rule which is restricting the content based on the condition.
Name : Incident query
Table : sys_script (Business rule)
Resolution
Change the condition based on the requirement. As this is an OOB business rule please make a note of this change because this might change with new releases.
Additional Information
For more information on business rules please go through below documentation.