53 views

Description

Catalog Variable values appears blank/empty in Service Portal RITM record after submitting a catalog item. However, the same record shows the variable value in the platform UI.

Release or Environment

All Versions

Cause

This happens if the catalog variable values is dynamically set by a Catalog client script. (this value doesn't exist in the sys_choice/question_choice)
This is the expected behavior. The Service Portal can only display the Display value, whereas the Platform can display both value and Display value.

Resolution

 Add all the required answer options (question_choice/sys_choice) to the variable (item_option_new) record and then use the OnChange Catalog client script to set the variable answers from the existing sys_choice/question_choice records.

Article Information

Last Updated:2020-09-09 09:34:23
Published:2020-09-09