Notifications

46 views

Symptoms


Users are redirected to "id=form" instead of "id=ticket" in Service Portal via URI and URI_REF in email notification links

Release


Any release supporting Service Portal

Cause


"mapUrlToSPUrl(String url)" method is used by email notification.

As explained in the following DOC for mapUrlToSPUrl(String url) method:

Transforms a URL requesting a list or form in the platform UI into the URL of the corresponding id=list or id=form Service Portal page.

Use this method to perform tasks such as redirecting a user after login to the correct Service Portal page when they request a platform UI form or list URL. Note that the id=list and id=form page targets are not customizable.
Note: Table, sys_id, and sysparm_query values are preserved from the original URL; sysparm_view is not.

Resolution


It works as expected

Additional Information


https://developer.servicenow.com/app.do#!/api_doc?v=jakarta&id=GSPS-mapUrlToSPUrl_S

Article Information

Last Updated:2018-11-19 19:54:14
Published:2018-11-20