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Knowledge articles display the attachments in the platform but not in Service Portal - Support and Troubleshooting
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  • Knowledge articles display the attachments in the platform but not in Service Portal
KB0717952

Knowledge articles display the attachments in the platform but not in Service Portal


996 Views Last updated : Dec 26, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Knowledge articles display the attachments in the platform but the attachments for the same articles are missing in Service Portal

Release

All

Cause

Angular Provider: "spAttachmentManager" is missing on 'KB Article Page' widget or issue is related to custom KB Article Page widget 

 

Resolution

  • Navigate to Service Portal -> Widgets
  • Open the Widget being used to render the knowledge article page. Out of box (OOB) version is named 'KB Article Page'
  • Scroll down to the related list named "Angular Provider" on the sp_widget form and click on the Edit button and search for 'spAttachmentManager' in the Collection, then add it to the right side of the slushbucket
  • If using custom 'KB Article Page' widget, compare the custom widget with OOB 'KB Article Page' widget to make sure it has all related updates and is in sync with the out of box version of the same widget.  

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