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Symptoms


The issue is that after upgrade to London, the homepage search does not work as expected on Service Portal when entering the keywords on the search page.

Steps to reproduce:

  1. Navigate to Service Portal.
  2. Enter a search term in the home page search bar
  3. Result of search page appears which displays the result for the first search.
  4. On this same page, search for a different team by entering a new keyword in the search bar next to the breadcrumb on the top right corner (DO NOT refresh).
  5. ISSUE: Search results do no get updated for second search. 

Release


London

Cause


This reason is that in London release, the search features are enhanced by using "Faceted Search Widget" and for that you have to activate the new search under "Service Portal > Page route maps". 

In new instances, search facets are enabled by default. If upgrading from a previous release, enable search facets by activating a record in the Page Route Maps [sp_page_route_map] table. This docs link has detailed steps on how it can be activated.

Resolution


To enable search facets after upgrade, activate the page route map record to route your search results to render in the sp_search page. 

  1. https://instance-name.service-now.com/nav_to.do?uri=sp_page_route_map.do?sys_id=3821492587001300a785940307cb0bef 
  2. Set the "Active" field to true. 

Additional Information


Legacy: Search Page Widget

Enable Search facets

 

Article Information

Last Updated:2018-11-14 14:02:03
Published:2018-11-14