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Why request description appears twice in HR Service Portal in To-do list or HR Tasks? - Support and Troubleshooting
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KB0717764

Why request description appears twice in HR Service Portal in To-do list or HR Tasks?


894 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Go to HR service portal, and click on "View All" requests, you will see request description is repeated 2 times on the links.

Release


Any supported release.

Cause


Following widget, renders the HR case header menu via below code.

HRJ Task Header (https://<Instance Name>.service-now.com/nav_to.do?uri=sp_widget.do?sys_id=5aa9a44f9380320092051d1e867ffb8a)

function getDescription(recordInfo) {
var util = new hr_PortalUtil();

var hrTables = new GlideTableHierarchy(recordInfo.sys_class_name).getTables();

if (hrTables.indexOf('sn_hr_core_case') > -1) {
var grCase = new GlideRecord(recordInfo.sys_class_name);
var caseExists = grCase.get(recordInfo.sys_id);

if (caseExists) {
util = new hr_PortalUtil(grCase);
return util.getCaseTitle();
}
}


Above code invokes below script include method to get the description to display on the menu,

hr_PortalUtil(https://<Instance Name>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=3c764fda534032003585c3c606dc34e9)

getCaseTitle: function() {
var title = this._getTitleFromCaseConfiguration(this._gr, this._caseConfigForTicketPage);
if (!gs.nil(title))
return title;
},


In the above code, _getTitleFromCaseConfiguration function refers below configurations,

HR Service Based Case Configurations

https://<Instance Name>.service-now.com/nav_to.do?uri=sn_hr_core_config_case.do?sys_id=c4e9872eb3900300f5302ddc16a8dc91
https:/<Instance Name>.service-now.com/nav_to.do?uri=sn_hr_core_config_case.do?sys_id=86d9872eb3900300f5302ddc16a8dc8b

These configurations are set with hr_service,subject_person.name,short_description to display on the portal for menu items.

Since the HR service and short description has almost same data, it appears as redundant data on the portal.

Resolution


Please change above configurations so that you have either,

  • hr_service,subject_person.name OR
  • subject_person.name,short_description

Additional Information


Service Portal

Script Include


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