Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
The Variable Editor in "Print Friendly Version" view does not display reference icon. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • The Variable Editor in "Print Friendly Version" view does not display reference icon.
KB0717257

The Variable Editor in "Print Friendly Version" view does not display reference icon.


763 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


The Variable Editor in "Print Friendly Version" view does not display the same between the instances.

To see this issue, open a request item in the "Print Friendly Version" view with the following URL: 

https://<instance>.service-now.com/sc_req_item.do?sys_id=<sys_id>&sysparm_media=print

 

On one of the instance it does not show the reference button like the other instance.

Following screenshot shows the comparison

(Left side: the reference variable does not have the reference icon. Right side: the reference variable have the reference icon)

 

Release


UI16

 

Cause


This is caused by a system property "glide.ui.reference.readonly.clickthrough"

 

Resolution


Set the property to true, you will see the "Print Friendly Version" view like the screenshot on the right side (the icons not showing).

Set the property to false, you will see the "Print Friendly Version" view like the screenshot on the left side (the icons showing).


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.