Issue
Unable to add field to on Vendor risk form.
Cause
UI View Vendor Risk is in "GRC: Vendor Risk Management" Scope.
Resolution
This behaviour was happening due to the UI View being in the "GRC: Vendor Risk Management" application.
Since this view is in the GRC application, your user will also need to be in this application to change the fields. Have the user change the application in the application picker. Then, go to 'Vendor Risk' view and clicked on 'Configure available fields'. This will allow you to add the field.