Notifications

16 views

Symptoms


The worknotes are not getting updated or not showing in activity on table Removal Candidate (samp_sw_reclamation_candidate).

Release


Jakarta or later..

Cause


Here the issue is not updating the worknotes. Originally the worknotes are getting updated but it is not being shown on the activity log. Reason for this is auditing is not enabled on it and it is expected that the journal fields work only on audited tables.

https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/task-table/reference/r_JournalFields.html

Resolution


Turn on auditing for this table and this can be very simple as below:

#1 Turn on Auditing on tables:

https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/time/concept/audited-tables-2.html

#2 Add the Additional comments field on the form layout and then remove it:

  • Change the application to "Software Asset Management Professional"
  • Now open one of the record on Removal Candidate able and right click on header and select form layout and add the field.

https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/form-administration/task/t_ConfigureAForm.html

 

Additional Information


https://docs.servicenow.com/bundle/kingston-software-asset-management/page/product/software-asset-management2/task/t_AddAReclCandidate.html

https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/form-administration/task/t_ConfigureAForm.html

https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/time/concept/audited-tables-2.html

https://docs.servicenow.com/bundle/kingston-platform-administration/page/administer/task-table/reference/r_JournalFields.html 

Article Information

Last Updated:2018-11-03 14:02:11
Published:2018-11-03