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In domain separated instance user is unable to see the records under related list on the form, but able to see same records in list. - Support and Troubleshooting
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  • In domain separated instance user is unable to see the records under related list on the form, but able to see same records in list.
KB0716622

In domain separated instance user is unable to see the records under related list on the form, but able to see same records in list.


1684 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


In domain separated instance user is unable to see the records under related list on the form, but able to see same records in list.

Release


All

Environment


Domain Separated Instance

Cause


This is happening as record domain scope is enabled 

Resolution


Record scope uses the domain of the record and is active when viewing the form of any record. In the Base system, record domain is enabled. 

-- Property 'glide.sys.domain.use_record_domain_for_data', this property when has the value true restricts domain scope to the record's domain for all data. That means if the record is in Domain A and some records under related List are in the Different domain than Domain A, the user will not see records under related as record scope enabled. But once user open related list in a list they will see the records if they have access to see records in that domain.

Please Note: Users always have access to data from domains that have been explicitly granted to them by domain visibility. They will not just see it in the related list due to record scope

Additional Information


Domain scope can be tricky based on the properties, please read more about it in detail in the documentation: Domain scope, Default domain scope, and Domain scope properties and user preferences


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