Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Approval records are not displayed to users who do not have approver_user role - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Approval records are not displayed to users who do not have approver_user role
KB0716592

Approval records are not displayed to users who do not have approver_user role


3537 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Approval records are not displayed to users who do not have approver_user role

Release


London

 

Cause


There is a slight change in the code of the 'Approvals' widget in London. In line 128 of the Server Script of the widget: 

data.showApprovals = gs.getUser().hasRole('approver_user'); 

According to this code, data.showApprovals will be true only if the user has 'approver_user' role.  it is an expected behavior due to the change in the Approvals widget.

Resolution


Add 'approver_user' role for the user

Additional Information


https://docs.servicenow.com/csh?topicname=approvals-widget.html&version=latest


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.