Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
User with right role acess not able to save the record - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • User with right role acess not able to save the record
KB0716575

User with right role acess not able to save the record


920 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

User-provided the right roles, to edits the records but still not able to save or update the record on the form. Also if the record is accessed from a different module, the user can able to save and edit the record.

Cause

The Module from where the record is accessed is configured with a particular view name, but the view does not exist

Resolution

  1. Go to the module from where records been accessed
  2. Click the pencil icon to edit the module
  3. Check the View name under the Link Type section, if the view is not configured with the same name, create one or remove the name to set it to the default view

Related Links

Module link types


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.