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Metrics for "Actual end date" (work_end) are not getting triggered once the parent Project is closed - Support and Troubleshooting
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KB0716548

Metrics for "Actual end date" (work_end) are not getting triggered once the parent Project is closed


698 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


  • Metrics for "Actual end date" (work_end) field are not firing when "Actual end date" field value is changed after the parent Project is closed

Release


Kingston Patch 9

Cause


The metric is being set on the pm_project table, rather than on the pm_project_task table. This is the issue.

Resolution


To test the above, a metric was created in an OOB (Out of Box) Kingston instance for the "Actual end date" (work_end) field on the pm_project table. Both a Project and a child Project Task were then created.

When the newly created Project Task was closed, a value was populated in the "Actual end date" field on the Project Task. This is expected. A "metric.update" entry was created in the Event Logs, as the parent Project was still open and active (it closed just after the child Project Task was closed).

After the Project was closed (active = false), the value within the "Actual end date" field was manually changed to see if another "metric.update" entry would be created in the Event Logs. While the change did save to the Project Task and was reflected in the parent Project after a short delay, no "metric.update" entry was created in the Event Logs as the parent Project was active = false.

This is expected behavior for the Platform.

To properly create a metric for "Actual end date" which fires even if the parent Project is active = false, create the metric on pm_project_task rather than on pm_project. This will allow changes to the "Actual end date" field to fire the metric properly, and reporting can be done off of said metric.


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