Issue
Symptoms
Unable to render to Knowledge Base in Service Portal
Release
Any release supporting Service Portal
Cause
Service Portal and Knowledge Base plugins were not activated appropriately
Resolution
- Navigate to sys_properties table (sys_properties.list)
2. Search for 'glide.war' and 'glide.war.assigned' and make sure they have the same value (aka, there isn't a pending/ongoing upgrade)
3. Make sure the current Application scope is 'Global'.
4. Create a system property glide.upgrade.optimize.in_family with type "true | false" and set it to false
5. Re-activate the following plugins in the correct order:
Service Portal for Enterprise Service Management (ID: com.glide.service-portal.esm)
Service Portal - Knowledge Base (ID: com.glide.service-portal.knowledge-base)
6. Set the system property glide.upgrade.optimize.in_family via sys_properties.list to true