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Permalink does not appear on certain knowledge base articles - Support and Troubleshooting
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  • Permalink does not appear on certain knowledge base articles
KB0716387

Permalink does not appear on certain knowledge base articles


454 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

On some of the articles in the knowledge base portal, the permalink disappears.

Cause

The customer had enabled visibility of 'Most Recent task' on the page and attached lots of tasks to that article.

We identified OOB UI script named KnowledgeIframeFix seems to be impacting the behavior. This script is used to set the height of the iframe which holds the knowledge article.

uri=sys_ui_script.do?sys_id=7d41c51cdb1ca2005bc67b7e0f96197d

In the script KnowledgeIframeFix 'snc-article-incidents' Most Recent tasks section is not covered in the height calculation for the frame on line number 30.

Also in this customer scenario, the file is missing 'snc-article-attachments' attachment section which was added in the Kingston release.

Resolution

The workaround is to add both 'snc-article-attachments' and 'snc-article-incidents' at line number 30. This should fix the issue.

see e.g. below

else if (iframePageIs('kb_view.do')) {
return getTotalHeight([
'body > .outputmsg_div',
'body > .navbar',
'.kb-view-content-wrapper',
'.snc-article-header-author',
'.snc-article-incidents',
'.snc-article-attachments',
'.snc-article-footer-section',
'.snc-article-footer'
], bottomMargin);
}

Please note however that modifying this file on the current version will be a customization and you need to be aware of it for future upgrades.


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