Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
When performing a 'Group by' on a list column/field, the groups are not displaying the correct records - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • When performing a 'Group by' on a list column/field, the groups are not displaying the correct records
KB0716335

When performing a 'Group by' on a list column/field, the groups are not displaying the correct records


2422 Views Last updated : Jul 24, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When performing a 'Group by' on a list column/field, the records within each of the group are not correctly grouped. They can appear in an "empty" named group or even other groups.

Release


All releases

Cause


This is caused by the column/field being configured using a calculated value set on the dictionary entry of that field. 

A calculated field works to show the combination of several fields in one field, which only displays on display of either the form or list.

Resolution


  1. Open up the records not correctly grouped
  2. Save the record, capturing the calculation done by the calculated value
  3. Open up the list and validate



The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.