Issue
Symptoms
When performing a Global Search for a record, it is not returning results even though that table has been indexed.
Release
All releases
Cause
This is due to that table not being defined within a Search Group which Global Search uses to display
Resolution
Ensure that the Search Groups are properly configured:
- Navigate to System Definitions > Search Groups
In the list that appears, you can open an existing group or create a new one.
We will be opening the existing "Tasks" group. - Once you have your "Text Search Group" record opened, click on 'New' under "Text Search Tables" related list
- In the new record, select the table that your record sits on and set the conditions
- Submit the new "Text Search Table" record
This should now configure your Global Search to return the records from that table.