Issue
Fix incorrect date formatting that may display after a record is submitted through the HR Service Portal, which includes a date field.
Release
Jakarta and later releases
Cause
This can happen when:
- The user profile is imported through an Excel file (.xls, .xlsx), .xml, or through Active Directory (AD) or LDAP integrations, and the date format is not defined correctly or there is a mismatch in the format.
- No date format is imported; it will take the system defined date and time format.
- The date format is incorrect. The request when viewed through portal shows the date field as shown in the following image.
Resolution
- Go to the sys_user.list
- Add the date format column in the list
- Verify if any of the record shows in blue. If any record is highlighted in blue, the date value for the specific user is not imported correctly.
- Select the drop down for date format, and select the correct format.