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Customer Service Management user is unable to write on field that per ACLs, he should be able to do so. - Support and Troubleshooting
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  • Customer Service Management user is unable to write on field that per ACLs, he should be able to do so.
KB0715666

Customer Service Management user is unable to write on field that per ACLs, he should be able to do so.


640 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


A user was given specific Customer Service Management roles and since then, the user has been unable to perform tasks that, per ACLs, he should be able to do so.

For example, to update a field he must pass an ACL that requires sn_customerservice_manager. The user has the role, but he still cannot write in the field.

Release


All releases (Jakarta, Kingston, London)

Cause


This issue can happen when the user contain sn_customerservice.customer role combined with other internal roles. 

sn_customerservice.customer is an external role and is not supposed to be combined with internal roles like sn_customerservice_agent, itil, sn_customerservice_manager, etc.

Resolution


Do not combine sn_customerservice.customer with other internal roles in an user profile or user group.

 


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