Issue
When "public" explicit role is added to login CMS page, it throws "Security constraints.." message when tried to access this login page as an unauthenticated user.
Cause
- One of the scenarios as to when "public" role gets added to CMS login page is by activating "Customer Service" plugin.
- This role can't be removed from your desired login page as it's defined on our platform code that login page(s) need(s) to have public role.
- For resolving this issue, Go to sys_public table and look for the record with Page being "view_content". Check whether that record is inactive => If it is inactive, please activate it by setting Active field to true.
- Because public pages do not require login, CMS pages (like login page) do not use SSO. "view_content" page is private only in cases when you like CMS to use SSO.
Related Links
Configure CMS sites for single sign-on (SSO): https://docs.servicenow.com/administer/content_management/task/t_CMSSitesAndSingleSignOn.html