Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Why 'public' role added to CMS login page can't be removed. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Why 'public' role added to CMS login page can't be removed.
KB0715658

Why 'public' role added to CMS login page can't be removed.


480 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

When "public" explicit role is added to login CMS page, it throws "Security constraints.." message when tried to access this login page as an unauthenticated user.

Cause

  • One of the scenarios as to when "public" role gets added to CMS login page is by activating "Customer Service" plugin.
  • This role can't be removed from your desired login page as it's defined on our platform code that login page(s) need(s) to have public role.
  • For resolving this issue, Go to sys_public table and look for the record with Page being "view_content". Check whether that record is inactive => If it is inactive, please activate it by setting Active field to true.
  • Because public pages do not require login, CMS pages (like login page) do not use SSO. "view_content" page is private only in cases when you like CMS to use SSO.

Related Links

Configure CMS sites for single sign-on (SSO): https://docs.servicenow.com/administer/content_management/task/t_CMSSitesAndSingleSignOn.html


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.