Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
g_form object and its functions such as setValue() are not working correctly when used in a service portal widget's client controller field - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • g_form object and its functions such as setValue() are not working correctly when used in a service portal widget's client controller field
KB0715296

g_form object and its functions such as setValue() are not working correctly when used in a service portal widget's client controller field


11535 Views Last updated : Jul 24, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

The use of the "g_form" as a global object and its functions such as setValue(), getValue(), and setMandatory() are not working as expected when they are used in a service portal widget's client controller field.

Cause

"g_form" as a global object cannot be used in a widget client controller so its functions are not supported either.

Please refer to the following documentation for this information: Widget API reference.

Resolution

Avoid using "g_form" as a global object and its associated functions directly in the widget's client controller and instead, use alternatives such as (catalog) UI policies and/or (catalog) Client Scripts to affect variables/fields.

It is, however, still possible to make use of "g_form" and its supported functions in the widget client controller through the use of a variable type Macro and embedded widget.

See the following documentation on how to use it: Replace a Service Catalog form script with a widget.



Related Links

Service Portal and client scripts


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.