Issue
Symptoms
Attaching Knowledge Articles to incident post knowledge article number and short description only under work_notes, not the whole content
Release
Kingston
Cause
System property "glide.ui.security.allow_codetag" set as False
Resolution
After setting the system property "glide.ui.security.allow_codetag" as true, it resolves the issue
Additional Information
There is OOTB Script include "KnowledgeAjax" has logic which says that when we attach any knowledge article on form, it checks the system property "glide.ui.security.allow_codetag" if it's false, it display Knowledge article number and short description only otherwise it will display the whole article on form.