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Symptoms


When setting the Instance options of the Virtual Agent Service Portal widget as documented here the Topic does not load after starting a new conversation and reloading the page, and instead you get a message about "An unrecoverable error has occurred." and are transferred to an agent.

Release


London

Cause


The sys_id you entered is most likely from the sys_cb_topic table which is where topics are stored when developing in the designer, and not the sys_cs_topic table which is where topics are stored as runtime data and is the correct place to get the sys_id for the widget options.

Resolution 


When getting the sys_id for your topic to set as the default in the instance options follow these steps. 


1) Navigate to sys_cs_topic.list
2) Find the record for the Topic you want to be the default in that widget instance
3) Right-click the record and select copy sys_id.
4) Use that sys_id in the widget options as "sysparm_topic=sys_id" and it should correctly start the widget with that topic as default. 

Additional Information


Full Docs link from above:

https://docs.servicenow.com/bundle/london-servicenow-platform/page/administer/live-agent/task/configure-virtual-agent-for-sp.html

Article Information

Last Updated:2018-10-11 12:41:18
Published:2018-10-11