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Unknown 'standard' Change Type when creating standard change request by template - Support and Troubleshooting
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  • Unknown 'standard' Change Type when creating standard change request by template
KB0714249

Unknown 'standard' Change Type when creating standard change request by template


750 Views Last updated : Aug 24, 2022 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


There is the Change Type called 'standard' in blue color when viewing the Change Request table. However, when checking the choice list configuration, there is no such option called 'standard' and the existing choice list is named 'Standard' which starts with Capital S.

 

'standard' Change Type:

 

The existing 'Standard' Change Type:

       

 

Reproduce steps:

  1. Search 'Standard Change Catalog' in the navigation bar and click it
  2. Choice either 'Network Standard Changes' or 'Server Standard Changes' to create a new standard change
  3. Notice it shows 'standard' in the Change Type field when the change creation window opens up

 

Note: if you click 'New' from the Change Request table to create a new change request, you can NOT reproduce the issue. There is no such option called 'standard' in the Change Type dropdown list

 

Release


Jakarta Patch 9c

Cause


When creating a change request with the standard change request template, it uses lowercase 'standard' to match the choice list by default. The value of the 'Standard' choice list is 'Standard' as per the screenshot above, so the system cannot locate the associated 'Standard' option, it will set it as 'standard' starting with lowercase 's' and mark it in blue which means this choice list is not set properly

Script to apply the Standard Change template: 'StdChangeUtilsSNC':
https://<instance name>.service-now.com/nav_to.do?uri=sys_script_include.do?sys_id=f10d6bf3931002003b7a7a75e57ffb73

Resolution


Ensure the value of the choice list 'Standard' is 'standard' which starts with lowercase 's'. The OOB setting is the lowercase

 


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