Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Getting an error "Invalid 'Table' selected on the List record" when modifying an Observable in SIR - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Getting an error "Invalid 'Table' selected on the List record" when modifying an Observable in SIR
KB0714120

Getting an error "Invalid 'Table' selected on the List record" when modifying an Observable in SIR


4620 Views Last updated : Jul 22, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

Getting error "Invalid 'Table' selected on the List record. The 'Task Observable' table is in application 'Threat Core', but the current application is 'Security Incident'." while modifying list layout under Observable in SIR.

Release

Kingston Patch6

Cause

It is working as expected. It is a platform limitation across scope. The only way to configure the column is the gear icon.

Resolution

Workaround available:

1) Switch to Security Incident scope 
2) Go to https://<InstanceName>.service-now.com/nav_to.do?uri=sys_ui_list.do?sys_id=54b33da10b0222002e64a3e337673ab6 

OR

--Type sys_ui_list.LIST in filter navigator

--Filter by [Name][contains][sn_ti_m2m_task_obseravable] AND [Parent][is][sn_si_incident] AND [Relationship][is empty]

--Open the record


3) Click 'New' Button on the List Elements 
4) Fill in field column name. e.g. observable.type (can dot-walk) 
5) Submit the record 
6) Go back to SI form and click show IOC 
7) Click the Gear on Observable related list, if desired column are there 
8) If not, click the' Gear' icon, (NOT right click to configure list) remove any or all the columns.. 
9) Save


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.