Issue
Symptoms
Access "Software Asset" -> "Content Service Setup" to turn on / off for each category then click on "Save" button.
The expected behaviour after click on "Save" is showing the message:
"Selection(s) for the Software Asset Management Content Service have been successfully saved."
In customer's case, the page didn't return any message after click on 'Save', indicate the save function is not working
Release
Kingston
Cause
"glide.security.use_csrf_token" in 'sys_properties' table has value set to false.
Resolution
set "glide.security.use_csrf_token" value to true
Additional Information
1. This "Opt-In" screen (first time access "Content Service Setup") will have the same behaviour (not response after click on the button) with the property value set as false.
2. When you enable Chrome debug -> Console, notice following error.