Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
How to change the length of data which can be stored within a label - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • How to change the length of data which can be stored within a label
KB0713634

How to change the length of data which can be stored within a label


1743 Views Last updated : Jul 13, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

How to change the length of data which can be stored within a label.

Release

Any

Cause

These fields are core out-of-the-box elements protected from migration via update sets and amending them may result in issues in the future as you upgrade your instance.

Resolution

Increasing the label length is not recommended! There should not be any need to increased beyond 80 Chars.

There are other options such as:

  1.  If you want users and customers to enter data into fields of a record, use a record producer.

    The Catalog Builder tool can create a Record Producer for any task-based table and you can select columns to add as Variables to the Record Producer. The Variables each have a "Question" field that has a default length of 255 characters and can be used to prompt the user with a question. For more info on these tools, see the following documentation links.

    Catalog Builder | Record Producer | Service Catalog Variables | Creating Record Producers From Tables

  2. If you have a high level user / admin that wants to know more info about a field's data, add hints to the label field.

    The Hint field can be used to show longer text when a user hovers their mouse over a field label.

    Change Field Label Or Hint

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.