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'itil' roled users are not able to see the 'Closed' state on the choice list for incidents - Support and Troubleshooting
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KB0713125

'itil' roled users are not able to see the 'Closed' state on the choice list for incidents


1530 Views Last updated : Apr 18, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When 'itil' roled users are accessing the incident form and attempting to change the state field to 'Closed', this option is not available to them.

Release


All releases


Cause


This is caused by the following Client Script which checks whether users have the 'itil_admin' role.

https://<instance-name>.service-now.com/sys_script_client.do?sys_id=38c58af84657628200aeb11d8295f42c

Resolution


  1. Open up the following Client Script - "(BP) Hide Choice - Closed"

    https://<instance-name>.service-now.com/sys_script_client.do?sys_id=38c58af84657628200aeb11d8295f42c

  2. Change the 4th line to be the following:

    if (g_user.hasRole('itil'))

  3. Save the record.



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