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Some variables are empty/blank in Task tickets after submitting the request. - Support and Troubleshooting
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  • Some variables are empty/blank in Task tickets after submitting the request.
KB0713095

Some variables are empty/blank in Task tickets after submitting the request.


4168 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


After submitting the catalog item request, few variables in the task ticket of the request are empty. But on the catalog item form while submitting, the variables are not empty/blank. 

Release


London

Cause


When a variable is in a variable set and the name of the variable and the variable set it belongs is same, after submitting the request, the variable will be empty/blank in RITM. In versions previous to London, a warning message will be shown if the variable and the variable set has the same name.

In London, SN team has enhanced the behavior of the variable set. The variable set will behave as a variable. Hence it is not a recommended configuration to have the same name for the variable set and the variable as this might cause issues such as generating blank values in task tickets, users not able to submit the request etc.,

 

Resolution


In order to resolve the issue, make sure the name of the variable and the variable set is different.

Reference

Refer the following London release notes to know more about the modifications to variable set.

Service Catalog release notes


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