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Bulk discovery fails for network devices configured with SNMPv3 - Support and Troubleshooting
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  • Bulk discovery fails for network devices configured with SNMPv3
KB0713043

Bulk discovery fails for network devices configured with SNMPv3


938 Views Last updated : Feb 6, 2023 public Copy Permalink
KB Summary by Now Assist

Issue

Bulk discovery fails for devices configured with SNMPv3, but when quick discovery is run, it is successful for the single device.

Network devices cannot be found using scheduled discovery. However, Quick Discovery is prosperous. Devices utilizing SNMP V3 experience this problem.

Steps to Reproduce:

  1. Create a schedule for Network Switches/Routers using the behaviour "SNMP" and set the SNMP version to V1/V2C.
  2. Run the "Discover Now" 
  3. Discovery will not trigger SNMP probes, it will trigger SSH Probes and the job will fail.
  4. Executing the Quick discovery for the same CI/IP, it will trigger SNMP probes and the Discovery will get successful.

Cause

SNMP version mismatch

  • Probably the same SNMPv3 Engine ID is configured for all network devices under a single scheduled discovery.
  • This results in discovery not performing well and failing to discover devices correctly.

Resolution

  • Check that the network devices do not have the same engine ID configured on the SNMPv3 settings.
  • The SNMP Engine ID must be unique for the administrative domain so that no two devices in a network have the same Engine ID.
  • From the Quick Discovery job logs, check if the SNMP version used is V3.
  • If it is using SNMP Version V3 then change the "Use SNMP Version" to V3 in the Discovery Schedule.
  • By default, in the Discovery schedules, the SNMP version selected would be "V1/V2C".

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