Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Agent Workspace loading slowly - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Agent Workspace loading slowly
KB0712983

Agent Workspace loading slowly


4223 Views Last updated : Mar 14, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Agent Workspace loads slowly the first time a user tries to access it. Typically users will see a blank white page for 20 to 30 seconds before the workspace finally loads.

After the initial slow loading, the workspace will load very quickly for that user.

Cause

GraphQL schema is rebuilding in the background.

  • Any changes to tables & dictionary configurations in the platform will require the GraphQL schema to be rebuilt.
  • This rebuild is done on demand (the first time a user accesses the Agent Workspace) on each app node.

Resolution

Once the schema has been rebuilt on each node, the issue will clear up on its own.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.