Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
How to resolve Automated Test Framework (ATF) error "This step's 'Field values' field is assigned an output value from a step that no longer exists" - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • How to resolve Automated Test Framework (ATF) error "This step's 'Field values' field is assigned an output value from a step that no longer exists"
KB0712377

How to resolve Automated Test Framework (ATF) error "This step's 'Field values' field is assigned an output value from a step that no longer exists"


1377 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Set Field Values step fails with below error message,

This step's 'Field values' field is assigned an output value from a step that no longer exists. 
To fix this problem, edit this step and replace the value for the 'Field values' field with a valid value.

Below screenshot shows the same error message in full context,

Below screenshot shows the affected "Set Field Values" step in detail,

Release


Any supported release. 

Cause


The step 1 which is referred in the above screenshot is de-activated by the user as below, however "Set Field values" step depends on Step 1 output and hence "Set Field values" step errors out.

Resolution


Correct the "Step field values" step so that it doesn't refer Step 1 output.

OR

Activate the Step 1.

Additional Information


Automated Test Framework

Automated test form steps

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.