Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Non-admin users are not able to edit their own templates when using the toggle template bar - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Non-admin users are not able to edit their own templates when using the toggle template bar
KB0711956

Non-admin users are not able to edit their own templates when using the toggle template bar


2194 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


When non-admin users try to edit their own templates using the toggle template bar they are unable to do so as the "Edit" button/link is not available to them.

Release


All releases

Cause


The users are failing the write operation table level ACL on sys_template table. Specifically this out-of-the-box ACL with sys_id of "8f3271b2c0a8016501fab9eb78d21e95".

Resolution


1) Navigate to System Security > Access Control (ACL)

2) Open the record with sys_id "8f3271b2c0a8016501fab9eb78d21e95"

(/nav_to.do?uri=sys_security_acl.do?sys_id=8f3271b2c0a8016501fab9eb78d21e95)

3) Make sure that it has the OOB values. If not, change them to these values:

Type: record

Operation: write

Admin overrides: checked

Name: Template [sys_template]. None

Requires role: template_editor

Condition: User is (dynamic) Me

Script: make sure this is blank

4) Save the change

Additional Information


If the above ACL is OOB then users should have no problem editing the templates. The ACL might have not been updated to OOB due to either having been customized before and did not receive the OOB update when upgraded or the OOB update was skipped entirely during an upgrade.


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.