Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Why out of the box provided database view "matching_user_group_skills" not working and displaying message "Error MessageSyntax Error or Access Rule Violation detected by database"? - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Why out of the box provided database view "matching_user_group_skills" not working and displaying message "Error MessageSyntax Error or Access Rule Violation detected by database"?
KB0697386

Why out of the box provided database view "matching_user_group_skills" not working and displaying message "Error MessageSyntax Error or Access Rule Violation detected by database"?


1107 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


While running the out of the box provided database view "matching_user_group_skills", getting below error:

Error Message Syntax Error or Access Rule Violation detected by database (Unknown column 'sys_user_group0.type' in 'where clause')

Release


Any supported release. 

Cause


Reviewing the "matching_user_group_skills" database view revealed that system couldn't find the "user_task_stats" table and hence it had orange color dot on the view tables section of the database view. 

Table "user_task_stats" is coming from a plugin called "Resource Matching Engine" (Id="com.snc.matching_rule"). And this plugin was not active on the affected instance and hence "user_task_stats" table was not available.

Eventually this failed the "matching_user_group_skills" database view. 

Resolution


Get the "Resource Matching Engine" (Id="com.snc.matching_rule") plugin activated, it should create the missing "user_task_stats" table and hence should resolve the issue with "matching_user_group_skills" database view.

Additional Information


Database views

Resource Matching Engine plugin


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.