36 views

Symptoms


"Roles" field does not appear on the categorty form. Even after adding in the form via right click context menu->Configure -> Form Layout,also "Roles" field does not appear on the category form

Release


All

Cause


The reason "Roles" field does not appear on the form is due to the OOB onLoad Client script- "Hide roles field"

https://<instance -name>/nav_to.do?uri=sys_script_client.do?sys_id=e9cab6b2c3212100c8b837659bba8

 

The above client script evaluates whether the user criteria is enabled for sc_catalog or not. If the system property "glide.sc.use_user_criteria" is set as false shows the roles fields, if set as true it hides the roles field.

Resolution


If "Roles" field need to appear, set the system properties "glide.sc.use_user_criteria" to be false

Additional Information


Service Catalog properties

Article Information

Last Updated:2018-09-13 21:03:25
Published:2018-09-03