Issue
Symptoms
Unable to add "No Cart" field to the catalog item if the "Use cart layout" is set to true
Release
All release versions
Cause
The "Use cart layout" field is set to true
Resolution
This behavior is as per design and you would need to uncheck "User cart layout" on the catalog item form to view the 'No Cart' field.
Additional Information
https://docs.servicenow.com/csh?topicname=t_ConfigureCartLayout.html&version=latest#ariaid-title5