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Relationship builder not working on some CIs, user cannot save form - Support and Troubleshooting
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  • Relationship builder not working on some CIs, user cannot save form
KB0696861

Relationship builder not working on some CIs, user cannot save form


1380 Views Last updated : Apr 8, 2025 public Copy Permalink
KB Summary by Now Assist

Issue

User attempts to create a relationship by using the Relationship Editor by following the steps below:

1. Go to the CI

2. Open up the Relationship Editor by clicking the plus icon:

3. Select the CI you want to relate to and click the plus icon in the Relationships list. You cannot save the form due to the issue described in this document:

Cause

This issue is caused by related items in the cmdb_rel_ci table containing an empty type. You can find out the records that contain an empty type field in cmdb_rel_ci by browsing to the url below:

https://<instance-name>.service-now.com/cmdb_rel_ci_list.do?sysparm_query=type.sys_nameISEMPTY

Resolution

  1. Go to the the list below:
    https://<instance-name>.service-now.com/cmdb_rel_ci_list.do?sysparm_query=type.sys_nameISEMPTY
  2. Assign a relationship type. This field should not be empty.

Related Links

CI relationship editor


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Attachments

Attachments

  • relationshipeditor.png
  • saveandexitgrayedout.png

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