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Symptoms


When we try to set the "Priority" field via before update / insert business rules as shown below, it doesn't work.

Release


Any supported release. 

Cause


Priority look up definition ("https://<instance name>/dl_definition.do?sys_id=302849102b031000de0aba36a3fd5631") is active on all out of the box instance by default and it will override the priority value set by the business rule. 

Resolution


As per business use case, if the priority value needs to be set only by business rule, make sure,

  • Business rule is either before insert/update (should not be after insert/update as the current object will not be available).
  • Priority look up definition is inactive

Additional Information


Incident Priority and data look up rules

Data look up and record matching

Business Rules

Article Information

Last Updated:2018-08-29 07:04:02
Published:2018-08-29