Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
"There is a JavaScript error in your browser console" error message appears when accessing the Service Portal form. - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • "There is a JavaScript error in your browser console" error message appears when accessing the Service Portal form.
KB0696644

"There is a JavaScript error in your browser console" error message appears when accessing the Service Portal form.


28427 Views Last updated : Jun 5, 2025 public Copy Permalink English (Original)
  • English (Original)
  • Japanese
KB Summary by Now Assist

Issue

When opening a form in the Service Portal, this JavaScript error displays: "There is a JavaScript error in your browser console".

Cause

This error typically originates in a client script that runs on the form. You will have to identify which script it is and troubleshoot from there.

Resolution

The browser developer tool console can provide more details about the error. To open it:

  1. Right-click anywhere on the form.
  2. Select Inspect
  3. Select the Console tab

Find the Client script that is causing the issue.

You have two options:

  • Update this script to work on both portal and back end views.
  • Write a different script to run only on the portal, and leave the current script to run only on the desktop.

Related Links

Some methods are not supported in mobile or service portals but work fine in native UI. Avoid such methods while creating client scripts for the portal. 

The following product documentation provides more explanation about unsupported methods. 

  • Service Portal and client scripts
  • Supported features in Service Portal
  • GlideForm - Client

The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.