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Symptoms


OOTB widget "Knowledge Bases Browse" widget doesn't show knowledge bases when cloned.

Release


Kingston

Cause


The cloned widget references a script include "KBPortalService" whose scope is restricted to "Knowledge Management - Service Portal".  Creating a clone of this script include in the global scope and changing the accessibility value to "All application scopes" fixes the issue.

Resolution


Ensure you are in the "Global" scope
1) Navigate to script includes "KBPortalService"
2) Observe the field 'Accessible from'. The value is set to "This application scope only" which means that this script includes can be called only within this application scope.
3) Right-click the form header and click on the UI action "Insert and Stay"
4) Change the  'Accessible from' value to  "All application scopes ".
5) Save the record
 
The widget should now display the Knowledge bases.

Article Information

Last Updated:2018-08-24 11:51:50
Published:2018-08-24