Issue
Changing the "Week Starts On" field on the Time Card does not save
Release
Jakarta Patch 9c
Cause
No Time Sheet on the time card so "Populate week starts on" Business Rule was running.
Resolution
There is not a timesheet attached, the "Populate week starts on" Business Rule will run and assign the "Week Starts on" field with what is defined in the Time Sheet Policy.
If you have a Time Sheet and want to change the date in a Time Card, this should be changed first on the Time Sheet.