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Attachments in emails, filenames greater than 60 characters, are renamed to ATT*.dat in Lotus Notes - Support and Troubleshooting
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KB0696085

Attachments in emails, filenames greater than 60 characters, are renamed to ATT*.dat in Lotus Notes


2131 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


If an email sent from ServiceNow contains an attachment, and if the attachment's filename is greater than 50 characters, their attachment name is observed as

ATT*.dat

in Lotus Notes email clients.

Release


All ServiceNow releases.

Environment


Lotus notes should be used by the end users.

Cause


An email that contains an attachment filename of Report containing a very long filename with more than 60 characters.csv would be composed like following example within the email headers:

Content-Disposition: attachment; 
    filename*0="Report containing a very long filename with more than 60
 cha"; filename*1=racters.csv

This composition conforms RFC2231, and utilized for handling long and international filenames. The issue seems to stem from Lotus Notes not supporting RFC2231: 3. Parameter Value Continuations extensions.

Resolution


You can either:

  • Ask Lotus Domino/Notes administrator to upgrade the clients to IBM Notes Feature Pack 9
  • Or if it's a scheduled report sending the attachment(s), change the report title to fewer characters, so an attachment with shorter names will be delivered to recipients. 

 


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