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Record Producer not carrying attachment files into resulting record - Support and Troubleshooting
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  • Record Producer not carrying attachment files into resulting record
KB0696061

Record Producer not carrying attachment files into resulting record


4714 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Record Producer not carrying attachment files into resulting record

 

Release


Kingston

 

Cause


The  UI page type variable named "Add attachment" (button) is pointing to a different table

 

Resolution


The variable that we use to add the attachment is the "UI page" type variable.
 
It has a method named saveCatAttachment() that saves the attachment in the "sys_attachment" table.
 
In that method, we should specify which table the record producer is generating the record.
 
Also, when the attachment is saved in the "sys_attachment" table, it has a "Table sys_id" field that links to the incident record using the "sys_id" of the incident record that is going to be generated by the record producer.
 
When we use current.initialize() in the record producer script, then the sys_id of the incident record that is going to be generated is altered. So this breaks the link between sys_attachment and incident records. So the attachment will not appear on the incident record.
 
So to resolve the issue, please remove the line in the script section of the record producer.

 


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