Skip to page contentSkip to chat
ServiceNow support
    • Community
      Ask questions, give advice, and connect with fellow ServiceNow professionals.
      Developer
      Build, test, and deploy applications
      Documentation
      Find detailed information about ServiceNow products, apps, features, and releases.
      Impact
      Accelerate ROI and amplify your expertise.
      Learning
      Build skills with instructor-led and online training.
      Partner
      Grow your business with promotions, news, and marketing tools
      ServiceNow
      Learn about ServiceNow products & solutions.
      Store
      Download certified apps and integrations that complement ServiceNow.
      Support
      Manage your instances, access self-help, and get technical support.
Opening a page that contains the Typeahead Search widget on the Service Portal shows 3 error messages - Support and Troubleshooting
  • >
  • Knowledge Base
  • >
  • Support and Troubleshooting (Knowledge Base)
  • >
  • Opening a page that contains the Typeahead Search widget on the Service Portal shows 3 error messages
KB0696029

Opening a page that contains the Typeahead Search widget on the Service Portal shows 3 error messages


1878 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Opening a page that contains the Typeahead Search widget on the Service Portal shows 3 error messages.

"java.lang.NullPointerException"

"Script source code logged to console"

"Failing widget: 'Typeahead Search' (fa20ec02cb31020000f8d856634c9ce9)"

 

Release


All Supported

Environment


Service Portal

Cause


The instance of the Typeahead widget on the page has Additional Options set for contextual_search_source for a search source that does not exist. Would look something like below.

 

"contextual_search_sources": {
"value": "c96eb1686721220023c82e08f585effe",
"displayValue": "Service Catalog"
}

 

Resolution


Make sure customer has a valid sys_id for an existing search source.

 


The world works with ServiceNow.

Sign in for more! There's more content available only to authenticated users Sign in for more!
Did this KB article help you?
Did this KB article help you?

How would you rate your Now Support digital experience?

*

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

Very unsatisfied

Unsatisfied

Neutral

Satisfied

Very satisfied

What can we improve? Please select all that apply.

What are we doing well? Please select all that apply.

Tell us more

*

Do you expect a response from this feedback?

  • Terms and conditions
  • Privacy statement
  • GDPR
  • Cookie policy
  • © 2025 ServiceNow. All rights reserved.