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Why "com.glideapp.report.charting_v2.exceptions.ChartDataGenException: No matching records" showing up in logs? - Support and Troubleshooting
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KB0695944

Why "com.glideapp.report.charting_v2.exceptions.ChartDataGenException: No matching records" showing up in logs?


1460 Views Last updated : Apr 7, 2024 public Copy Permalink
KB Summary by Now Assist

Issue

Symptoms


Intermittently, following exception is logged in syslog.

No matching records: com.glideapp.report.charting_v2.exceptions.ChartDataGenException: No matching records: com.glideapp.report.charting_v2.datagen.single.score.json.SingleScoreJSONBuilder.buildResponseJSON(SingleScoreJSONBuilder.java:41)
com.glideapp.report.charting_v2.datagen.json.JSONBuilder.build(JSONBuilder.java:17)
com.glideapp.report.charting_v2.datagen.single.score.SingleScoreGenerator.generateJSONResponse(SingleScoreGenerator.java:42)
com.glideapp.report.charting_v2.datagen.single.score.SingleScoreGenerator.generate(SingleScoreGenerator.java:29)
com.glide.processors.report.run.SingleScoreRunProcessor.processRequest(SingleScoreRunProcessor.java:23)
com.glide.processors.report.run.ReportRunProcessor.process(ReportRunProcessor.java:44)
com.glide.processors.XMLHttpProcessor.processJavaAJAX(XMLHttpProcessor.java:151)
com.glide.processors.XMLHttpProcessor.process(XMLHttpProcessor.java:104)
com.glide.processors.AProcessor.runProcessor(AProcessor.java:483)
com.glide.processors.AProcessor.processTransaction(AProcessor.java:205)
com.glide.processors.ProcessorRegistry.process0(ProcessorRegistry.java:178)
com.glide.processors.ProcessorRegistry.process(ProcessorRegistry.java:167)
com.glide.ui.GlideServletTransaction.process(GlideServletTransaction.java:31)
com.glide.sys.Transaction.run(Transaction.java:2038)
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
java.lang.Thread.run(Thread.java:748)

Release


Any supported release.

Cause


Single score records are not configured with "Display Zero ( Show Zero)" to "true" ( tick on the check box) as shown in the below screenshot and hence  when there is no matching record system is displaying "no matching records" message and logging the exception. 

Resolution


For the Single score reports, make sure "Display Zero" is set to "true" (checkbox ticked) so that system will display 0 instead of logging exception when there is no match. 

On the sys_report.list, "Display zero" field is called with column name "Show zero". This will be useful, when you wanted to do list edit bulk amount of single score reports.

(you can find the affected single score reports via url,

https://<Instance name>/sys_report_list.do?sysparm_query=type%3Dsingle_score%5Eshow_zero%3Dfalse)

Additional Information


Single score report


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