Issue
Symptoms
Category picker pop-up not functioning in Knowledge articles. When we try and select a Category in Knowledge article using the viewfinder, it fails on the instance. Issue exists after upgrading to Kingston version.
Release
Kingston - All Versions
Cause
Script Include - KBCategoryCrud
The custom script include is making the category popup in the knowledge article form to break.
KBCategoryCrud is being called by the UI Macro kb_category_reference_lookup
What is the Out of the Box KbCategoryCrud script include in Jakarta Version? Does it include the canCreate() function?
No, This function is newly introduced on the kingston version in the script include KbCategoryCrud.
,
canCreate: function() {
var gr = new GlideRecord('kb_category');
gr.parent_id = this.getParameter('sysparm_id') || '';
var result = this.newItem("result");
result.setAttribute("canCreateCategory", gr.canCreate());
}
Resolution
Since the Out of the Box Script Include [KbCategoryCrud] was modified this issue has occurred. As a part of update to kingston version, the update for this file was skipped by the system automatically.
Revert back the script include to out of the box script include.
And if customer wish to modify KBCategoryCrud / any Script include , please create a new script include add the necessary code and invoke that on the UI Macros or anywhere it's being used.
Additional Information
How to revert back to Out of the Box Script Include - Product Documentation