Notifications

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Symptom

Page not found error (404 page)' error when going to to <instancename>/sp?id=actsub_notif_pref due to missing a sp_page (actsub_notif_pref) related to the com.snc.knowledge_advanced plugin 

Steps to Reproduce

  1. Upgrade an instance from Helsinki to Kingston patch 6.
    2. Activate Knowledge Management Advanced Installer plugin (com.snc.knowledge_advanced.installer) which would activate Knowledge Management Advanced (com.snc.knowledge_advanced) plugin.
    3. Activate Service Portal for Enterprise Service Management (com.glide.service-portal.esm) plugin.
    4. Navigate to <Your instance>/sp?id=actsub_notif_pref and notice the page not found error.

Release


Pre-Kingston patch 7

Cause


"Subscriptions and Activity Feed Framework" plugin was not active 

Resolution


1. Go to sys_properties table, search for 'glide.war' and 'glide.war.assigned'. Make sure they have the same value, aka, there isn't a pending/ongoing upgrade 
2. Make sure the current Application scope is 'Global' 
3. Set the system property glide.upgrade.optimize.in_family via sys_properties.list to false (if doesn't exist, create a new property with boolean true|false type) 
4. Re-activate "Subscriptions and Activity Feed Framework" plugin. 
5. Set the system property glide.upgrade.optimize.in_family via sys_properties.list back to true. 

Article Information

Last Updated:2018-08-22 15:47:55
Published:2018-08-22